SYSTEMS STATUS
GeorgiaFIRST Marketplace Issues Reported
Incident Report for USG Services
Resolved
ITS has confirmed that GeorgiaFIRST Marketplace is functioning normally at this time.

In the event that you experience any further issues with GeorgiaFIRST Marketplace, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Apr 21, 2016 - 10:51 EDT
Investigating
ITS is currently investigating reports of an issue with GeorgiaFIRST Marketplace. Affected users will not be able to access GeorgiaFIRST Marketplace. Additional information will be posted here when it becomes available.
Posted Apr 21, 2016 - 09:58 EDT
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST Marketplace).