SYSTEMS STATUS
GeorgiaFIRST Marketplace Issues Resolved
Incident Report for USG Services
Resolved
ITS has confirmed that GeorgiaFIRST Marketplace is functioning normally at this time.

In the event that you experience any further issues with GeorgiaFIRST Marketplace, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Sep 19, 2016 - 14:36 EDT
Investigating
Information Technology Services (ITS) is currently investigating reports of issues with GeorgiaFIRST Marketplace. Affected users will not be able to access the Staples Punchout. Additional information will be posted here when the issues are confirmed.
Posted Sep 19, 2016 - 12:56 EDT
This incident affected: GeorgiaFIRST Financials (GeorgiaFIRST Marketplace).