SYSTEMS STATUS
Communicator Issues Identified
Incident Report for USG Services
Resolved
ITS technical staff have addressed the certificate issue and confirmed that Communicator is functioning normally at this time.

In the event that you experience any further issues with Communicator, please contact the ITS Helpdesk at helpdesk@usg.edu or 706-583-2001.
Posted Apr 28, 2016 - 14:23 EDT
Identified
ITS has confirmed that issues with Communicator's web client are being caused by a certificate issue. ITS technical staff are working to restore full functionality of this system as quickly as possible. As a workaround, affected users may use the desktop client for Communicator. Additional information will be posted here as it becomes available.
Posted Apr 28, 2016 - 09:59 EDT